RSS Validator

Mark Pilgrim and Sam Ruby have posted a useful RSS Validator on the Internet Archive’s site. It validates both RSS 1.0 and 2.0, which is nice and nonpartisan of it. It even detected that I was using Movable Type and provided me with templates to fix both my RSS 1.0 feed and to upgrade my old 0.91 feed to an RSS 2.0 feed within MT. Thanks, guys!

Now all I have to do is re-code the PHP that generates my old RSS 0.91 feeds for the recent articles I’ve written and for tinywords.com’s daily haiku feed. That’s a little harder than replacing an MT template, I’m afraid. Ive been trying to avoid actually having to learn about RSS 1.0 and 2.0, but it looks like I may be forced to, now. At least those two feeds, despite being based on an obsolete version of RSS, are still valid.

RSS Validator